Форум интернет-магазина Микрокомп
0 Список сравнения
0 Избранные товары
0
Страницы: 1
mikrotik не раздает интернет, на mikrotik есть интернет, но он его не раздает
 
На самом mikrotik есть интернет, в new terminal, пинги на сайты идут. Но на компьютер инет не пробрасывается. Может кто подскажет где ошибка? Вот мой конфиг:


[admin@MSA] > export compact
# jan/03/1970 04:10:45 by RouterOS 6.22
# software id = Z1LE-2AL4
#
/interface bridge
add admin-mac=4C:5E:0C:E6:DE:73 auto-mac=no name=bridge-local
/interface wireless
set [ find default-name=wlan1 ] disabled=no l2mtu=2290 mode=ap-bridge name=\
   wlan
/interface ethernet
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=\
   ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=\
   ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local name=\
   ether5-slave-local
set [ find default-name=ether1 ] name=wan
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
   dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=XXXXXXXXX \
   wpa2-pre-shared-key=XXXXXXXXX
/ip pool
add name=lan-dhcp ranges=192.168.25.10-192.168.25.253
/ip dhcp-server
add address-pool=lan-dhcp disabled=no interface=bridge-local name=default
/interface l2tp-client
add add-default-route=yes allow=pap,chap,mschap1,mschap2 connect-to=\
   vpn.ural.mts.ru default-route-distance=1 dial-on-demand=no disabled=no \
   keepalive-timeout=60 max-mru=1450 max-mtu=1450 mrru=1600 name=l2tp-out1 \
   password=XXXXXXXXX profile=default-encryption user=XXXXXXXXX
/system logging action
set 2 remember=yes
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan
/ip address
add address=192.168.25.254/24 interface=bridge-local network=192.168.25.0
add address=10.7.13.6/24 interface=wan network=10.7.13.0
/ip dhcp-server network
add address=192.168.25.0/24 dns-server=192.168.25.254 gateway=192.168.25.254
/ip dns
set allow-remote-requests=yes servers=10.0.0.180,192.168.10.1
/ip dns static
add address=192.168.25.254 name=router
/ip firewall address-list
add address=192.168.25.0/24 list=inet
/ip firewall filter
add chain=input comment=icmp protocol=icmp
add chain=input comment=established connection-state=established
add chain=input comment=related connection-state=related
add chain=input comment=manage in-interface=bridge-local
add action=drop chain=input comment="all other drop" in-interface=wan
add action=drop chain=forward comment="Drop invalid connection packets" \
   connection-state=invalid
add chain=forward comment="Allow established connections" connection-state=\
   established
add chain=forward comment="Allow related connections" connection-state=\
   related
add chain=forward comment="Allow access to internet" in-interface=\
   bridge-local out-interface=wan src-address-list=inet
add action=drop chain=forward comment="All other drop"
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wan
add action=masquerade chain=srcnat out-interface=l2tp-out1
/ip route
add comment=isp distance=2 gateway=10.7.13.1
add comment="vpn servers subnet" distance=1 dst-address=10.0.0.0/24 gateway=\
   10.7.13.1
add comment="vpn servers sunet" distance=1 dst-address=192.168.10.0/24 \
   gateway=10.7.13.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip upnp
set allow-disable-external-interface=no
/snmp
set trap-community=public
/system clock manual
set time-zone=+04:00
/system identity
set name=MSA
/system leds
set 0 interface=wlan
/system ntp client
set enabled=yes
[admin@MSA] >
 
ip firewall nat
add action=masquerade chain=srcnat out-interface=wan
add action=masquerade chain=srcnat out-interface=l2tp-out1

Зачем два маскарадинга? Одного достаточно без указания out интерфейса. Инет я так понимаю по l2tp приходит. Все должно пахать с 1 правилом маскарадинга.
 
Приветствую.
Не могу раздать мобильный интернет.
Изделие RB951Ui-2HnD. Бьюсь несколько дней как рыба об лёд - толку ноль. Подскажите, что я делаю не так?
После сброса к заводским:
Активизирую интерфейс ppp-out1, в который воткнут 4G-модем. Маршрут на шлюз сотового провайдера появляется, пинги c роутера на внешние IP идут.
Отключаю дефолтное правило NAT, создаю новое, с указанием выходного интерфейса ppp-out1.
Проверяю интернет-подключение с компьютера - шиш:
Цитата
C:\Windows\system32>tracert -d 194.58.155.158

Трассировка маршрута к 194.58.155.158 с максимальным числом прыжков 30

 1    <1 мс    <1 мс    <1 мс  192.168.88.1
 2     *        *        *     Превышен интервал ожидания для запроса.
 3     *        *
Чего ему не хватает?
Полный конфиг следующий:
Цитата
# may/16/2015 16:14:57 by RouterOS 6.28
# software id = IHMP-TWR9
#
/interface bridge
add admin-mac=D4:CA:6D:FF:FC:FC auto-mac=no name=bridge-local
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=\
   ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=\
   ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local name=\
   ether5-slave-local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=\
   20/40mhz-ht-above distance=indoors frequency=auto l2mtu=2290 mode=\
   ap-bridge ssid=MikroTik-FFFD00 wireless-protocol=802.11
/ip neighbor discovery
set ether1-gateway discover=no
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge-local name=default
/port
set 0 name=usb1
/interface ppp-client
add apn=internet disabled=no info-channel=1 name=ppp-out1 port=usb1
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=\
   bridge-local network=192.168.88.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=\
   no interface=ether1-gateway
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" gateway=\
   192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=\
   established,related
add action=drop chain=input comment="default configuration" in-interface=\
   ether1-gateway
add chain=forward comment="default configuration" connection-state=\
   established,related
add action=drop chain=forward comment="default configuration" \
   connection-state=invalid
add action=drop chain=forward comment="default configuration" \
   connection-nat-state=!dstnat connection-state=new in-interface=\
   ether1-gateway
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=\
   yes out-interface=ether1-gateway
add action=masquerade chain=srcnat connection-type="" out-interface=ppp-out1 \
   src-address=192.168.88.0/24
/romon port
add disabled=no
/system clock
set time-zone-name=Europe/Moscow
/system leds
set 5 interface=wlan1
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=wlan1
add interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=wlan1
add interface=bridge-local
В порядке шаманизма пробовал в настройках NAT указать вместо ppp-out1 bridge-local и включить использование IP Firewall в настройках bridge-local, но это слабо помогает.
Пожалуйста, помогите сдвинуться с мёртвой точки. Наверняка ларчик просто открывается.
(Добавление)
Действительно просто. Чтобы заработало, достаточно было не указывать вообще никакой Out Interface. Только Src Address и Masquerade.
 
Цитата
Активизирую интерфейс ppp-out1, в который воткнут 4G-модем.
4Ж-модемы подключаются, как правило, как LTE-интерфейс и добавлять/активировать ppp-соединие не нужно... ваш "добавляет" именно ppp-интерфейс? какой модем? производитель, марка?
для lte-модема посмотрите, например это http://микротик.рф/document/statii/mikrotik_i_4g/ и http://nixman.info/?p=1991 и google вам в руки...
 
Цитата
ip firewall nat
add action=masquerade chain=srcnat out-interface=wan
add action=masquerade chain=srcnat out-interface=l2tp-out1

Зачем два маскарадинга? Одного достаточно без указания out интерфейса. Инет я так понимаю по l2tp приходит. Все должно пахать с 1 правилом маскарадинга.

Сделала как вы советуете. Ничего не изменилось. На микротике интернет есть, а на компьютере нет.
 
А пинги\трассировки с компа ходят? Правильные ли настройки сети на компе - адрес, шлюз, днсы?
 
Цитата
А пинги\трассировки с компа ходят? Правильные ли настройки сети на компе - адрес, шлюз, днсы?
Пинги с компа идут только до шлюза и днс-серверов. Настройки комп получает от микротика.
 
Ну как вариант, попробуйте воспользоваться Мастером настройки, в последних версиях Router OS таковой есть. Ресет полный конфига сделайте и по мастеру настройте - должно заработать.
 
Цитата
Ну как вариант, попробуйте воспользоваться Мастером настройки, в последних версиях Router OS таковой есть.
Хорошо. Сохраню конфигурацию и попробую воспользоваться мастером. Но вроде в мастере не было варианта с l2tp-client ?
 
Дайте ка угадаю - вы случаем не к билайн\корбина подключиться пытаетесь?
 
Цитата
вы случаем не к билайн\корбина подключиться пытаетесь?
Раньше сеть принадлежала региональному провайдеру, после перешла в руки МТС. Но схему подключения оставили прежнюю.
В кофигурации видно, что подключаюсь к vpn.ural.mts.ru
 
Ну тогда все ясно. И не будет инет работать ибо маст дай) Подключаться надо дюже сложно, простое L2TP не будет пахать. Я сам сломал весь мосг пока не нашел мануал. Ибо с типовой схемой коннекта которую юзает билайн\корбина  - инет настроить не так просто как оказалось, простого соединения не достаточно. Вот вам мануал, курите его.
http://tempfile.ru/file/3160765
 
Цитата
Вот вам мануал, курите его.
http://tempfile.ru/file/3160765
Спасибо. Буду изучать.

Ура! Дело сдвинулось с мертвой точки. Удалила все правила из настройки firewall и интернет заработал. Теперь буду разбираться с настройкой файрвола.
Страницы: 1