0 Список сравнения
0 Избранные товары
0
Страницы: 1 2 След.
IPTV через IGMP proxy настроить не могу
 
Провайдер предоставляет интернет и IPTV. По их словам интернет в одном влане и мультикастовый поток IPTV входящий в другом. Запросы на вещание этого потока отправляются в влане с интернетом. Так вот как настроить Микротик для получения услуги ТВ.

В интернете нашел что нужно настроить IGMP-Proxy. Вроде как сделал и даже upstream интерфейс активировался вроде как:

[maxim@ooe] /routing igmp-proxy> interface print
Flags: X - disabled, I - inactive, D - dynamic, U - upstream
# INTERFACE THRESHOLD
0 U internet_iptv_vlan 1
1 iptv_inbound_vlan 1
2 local_lan 1

файрвол выключил вообще. в log валятся сообщения в большом колличестве такого вида:

igmp-proxy debug|RECV IGMPv1 membership report from 192.168.104.125 to 239.255.255.100 on local_lan

у меня такой подсети даже нету в этом влане.
 
Эту ветку смотрели?
http://www.mikc.ru/forum/topic.php?forum=1&topic=75
 
Цитата
Эту ветку смотрели?
http://www.mikc.ru/forum/topic.p...m=1&topic=75

да я именно по ней и настраивал. Только там ТВ идет в одном влане и автоматические настройки я так понял и для ТВ и для интернета, а у меня запросы в интернет влане, а принимать в другом. Компания предоставляющая данную услугу поставила свой коммутатор и говорят что в одном порту у них два нетегированных влана.

как вообще можно продиагностировать проблему с ТВ. С интернетом то все понятно. Пакет отправил - пакет получил.
 
Не совсем понятно это как?

Цитата
и говорят что в одном порту у них два нетегированных влана.
 
вот я не понял как это. как можно вообще продиагностировать доступность IPTV?
 
а не подскажите для пользования этой функцией какую лицензию надо
л3 хватит или надо л4 ?

и еше на какой версии можно юзать эту функцию ?
 
судя по:
http://wiki.mikrotik.com/wiki/License_levels

должно и в L3 работать.
 
а с какой версии поддерживается данная возможность ?
 
товарищи прошу помощи. провайдер IPTV немного изменил порядок предоставления IPTV. По умолчанию подключаю ноутбук, получаю настройки по DHCP и включив плеер смотрю ТВ. Хотелось бы пророутить это дело в другую подсеть через микротик. Подскажите настройки. В интернете есть решения но, никто четко не пишет что они работают.
 
Хотелось бы вот еще какую ситуацию обсудить.

Дома провайдер дает 8 мегабит с услугами айпитиви. Так случилось что я на прилично долгое время уехал из дома в другой город. Здесь канал не меньше. Задача такова - получить мультикаст от провайдера через pptp соединение. Сам роутер подключен к инету через PPPoE

Вообщем говоря возникла проблема с IGMP прокси. Умеет ли прокси перекидывать мультикаст не на физический интерфейс ?

Имею подключение по впн, роутер подключен через PPPoE к интернету, имею прописаные все локальные маршруты, имею все нужные НАТ-ы.  Настраиваю игмп прокси - указываю принимающий мультикаст интерфейс, соответственно указываю подсети, откуда может идти вещание. Указываю второй интерфейс, он у меня ppp. В логах только вижу что игмп начал работать, но смотря статистику по пакетам (через винбокс) upstream показывает что  пакеты принимает, а на ppp интерфейсе все по-нулям.

В файрволе в цепочке INPUT и FORWARD на всякий случай разрешено igmp и все сети что учавствуют в этом действии. Грешным делом уже на всякий случай TTL UDP пакетов с широковещательно адреса увеличивал на единицу, но все равно никакого трафа что нужно на ппп не увидел.

Хотелось бы спросить, кто то применял такую схему, чтоб смотреть айпитиви местного провайдера через ВПН подключение и если да, то чем разруливали ?

Хотелось бы спросить, обязательно ли все шв пакеты при работающем IGMP PROXY должны попадать на другие интерфейсы, которые я указал  (кстати, на физ интерфейсах тоже я не увидел трафика)

Если кто заинтересуется решением вопроса - сеть смогу нарисовать, подпишу что куда, но вроде и так яснее некуда. Затык то в чем ? Именно в IGMP Proxy или все же в руках ?
 
Собственно говоря вопрос почти решен. Дело все же в софте видимо. В любом случае автоматически интерфейсы не подхватились для передачи мультикаста, пришлось сотый раз прочитать мануал и заметить строчку

/routing igmp-proxy mfc add source=192.168.0.1 upstream-interface=ether1 downstream-interface=ether2 group=224.10.10.11 disabled=no

Жаль что придется  вручную прописывать для каждого канала, но без Static multicast forwarding cache (MFC) entries не работает.
 
Посмотрите тут, может по этим инструкциям получется настроить.
Конфигурационные файлы настроек
 
Спасибо за ссылку. IGMP там вроде как нет, зато много других вкусных вещей, которые могут оказаться полезными. Спасибо !
 
У меня получилось настроить IGMP-Proxy на MikroTik MRTG (RB450G) следующим образом:

1. Пришлось скачать отдельно и поставить модуль multicast
2. В настройках Routing->IGMP Proxy настроил:
2.1. для интерфейса который смотрит в wan:
Код
/routing igmp-proxy add alternative-subnets=XXX.XXX.XXX.XXX/XX comment="" disabled=no interface=ether1-wan threshold=1 upstream=yes

т.е. указали сам интерфейс, указали что он upstream и указали alternative-subnets.
Насчет alternative subnets - подробнее: это используется для того чтобы указать сеть из которой непосредственно вещается UDP поток. Т.е. по IGMP поток заказываем, а по UDP он фактически с этой сети начинает бежать. Без  указания alternative-subnets у меня в WinBox в окне IGMP Proxy на вкладке MFC incoming interface и outgoing interface были Unknown. Когда прописал alternative subnets - стало правильно показывать интерфейсы, пакеты побежали в правилах фаервола. Собственно сеть из которой идет вещание узнал у провайдера.
2.2. Все остальные интерфейсы
Код
/routing igmp-proxy add comment="" disabled=no interface=all threshold=1 upstream=no

3. Настроил фаервол:
3.1. Разрешаем общаться по IGMP:
Код
/ip firewall filter add action=accept chain=input comment="IGMP inbound" disabled=no in-interface=ether1-wan protocol=igmp

3.2. Разрешаем пропускать UDP поток с серверов вещания на incoming. Я сделал тупо UDP и порт вещания. Порт вещания берете в плей-листе вашего VLC или на время отладки разрешаете весь UDP и смотрите по коннектам с сети вещания (alt-subnets) какой там порт. Засада в том что порт надо указывать dest-port а не src-port. Можно для пущей безопасности еще и источник указать откуда можно принимать такое, но я не стал.
Код
/ip firewall filter add action=accept chain=input comment="IP-TV UDP incoming" disabled=no dst-port=1234 in-interface=ether1-wan protocol=udp

3.3. Странно но поток UDP идет и в цепочке incoming и в цепочке forward (у меня web box при начальной настройке ее заджампил в customer, поэтому у меня написано customer):
Код
/ip firewall filter add action=accept chain=customer comment="IP-TV UDP incoming" disabled=no dst-port=1234 protocol=udp

4. Вот вроде и все.

PS: Я не ахти какой спец по сетям, поэтому прошу профи подсказать где я ошибся или сделал не оптимально. Может где дырень оставил и т.п.
 
у меня заработало без доп.правил в firewall и без доп. маршрутизации в ip routes

/routing igmp-proxy
set query-interval=2m5s query-response-interval=10s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=\
   172.16.0.0/16,78.107.196.0/22,233.0.0.0/8,239.255.255.0/24,224.0.0.0/4 \
   disabled=no interface=ether2_bee_lan threshold=1 upstream=yes
add alternative-subnets=192.168.193.0/24 disabled=no interface=bridge1 \
   threshold=1 upstream=no
add alternative-subnets=192.168.193.0/24 disabled=no interface=ether1_LAN \
   threshold=1 upstream=no
это мой конфиг. 192.168.193.0/24 - это моя локалка за натом (получаю по дхцп от микротика)
Bridge - это интерфейс в мою локалку+r52n
 
Телевидение не пробовал, пока нет его, а Vypress Chat сделать между локалками пока не получилось, хотя трафик http, ftp между локалками проходит, странно почему чат неработает, хотя никаких ограничений нет ни по протоколам ни по портам.
Локальные сети разные по диапазонам адресов.
У кого нибудь может работает чат, подскажите настройки, вроде все перепробовал.
 
cbeugene, Sages
IPTV у меня зараотало .....  Модем АДСЛ  бриджем +  RB750G  РРРое
Но при этом пропадает  трафик в локальной сети.....
Ничего не подскажете????
 
подскажу, в pppoe интерфейсе проверь галочку add default route. должна стоять.
 
Sages, спасибо за ответ
Цитата
подскажу, в pppoe интерфейсе проверь галочку add default route. должна стоять.
add default route  у меня галочка стояла и стоит.....  У меня маленькая сеть вайфай  через РБ411+r52
Вобщем что заметил: при включении  IP-TV  на стационарном ПК с него сразу  перестает  пинговаться  удаленная точка доступа  и скорость у клиентов падает до 20-30кбс....
Все  4 локальные порты RB750  объеденены в бридж.... 192.168.1.0 - моя локалка .

/routing igmp-proxy
set query-interval=1m query-response-interval=10s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=232.0.1.1/32 comment="" disabled=no interface=\
   "WAN  ether1" threshold=1 upstream=yes
add alternative-subnets=192.168.1.0/24 comment="" disabled=no interface=\
   ether5 threshold=1 upstream=no
add alternative-subnets=192.168.1.0/24 comment="" disabled=no interface=\
   bridge1 threshold=1 upstream=no

А вот несколько адресов моего плейлиста

</track>
<track>
<location>udp://@232.0.1.1:3000</location>
<title>Интер</title>
<extension application="http://www.videolan.org/vlc/playlist/0">
<vlc:id>1</vlc:id>
</extension>

<location>udp://@232.0.1.2:3000</location>
<title>Music</title>
 
Добрый день.

Я не очень большой специалист в сетевых технологиях, к сожалению все свои знания пришлось приобретать в полевых условиях. Очень прошу помощи настроить IP TV провайдер ТрансТелеКом (ТТК-Урал). Интернет от провайдера "отдается напрямую", настройки получаются по DHCP (никаких тебе PPTP и т.п.).

Железка RB951Ui-2HnD (RouterOS 6.27). Прочитал уже много тем и статеек про настройку IPTV. В том числе и на вашем форуме. Что сделано:

1. Установлен пакет мультикаст IGMP-proxy
2. Сделаны настройки upstream c интерфейса WAN для всех сетей 0.0.0.0/0
3. Добавлены правила firewall для IGMP и UDP.

В порт 2 включен ПК c IPTV плеером и VLC Player. При переключении каналов видно что улетают запросы и начитает литься UDP траффик с 238.1.1.0 на WAN. Но на bridge (и соответственно дальше) его уже нет... Почему? Что еще нужно добавить в настройки?

Страницы: 1 2 След.