Форум интернет-магазина Микрокомп
0 Список сравнения
0 Избранные товары
0
Страницы: 1
Подключение нескольких IP телефонов к внешнему (облачному) серверу, Есть микротик -- нужно пробросить порт 5060 и порты 10000-20000 к каждому из нескольких IP телефонов в локалке
 
Для одного телефона это работает:

CODE:
/ip firewall nat
add action=netmap chain=dstnat protocol=17(UDP) dst-port=5060 In-interface=uplink to-adresses=192.168.1.50 to-ports=5060

CODE:
/ip firewall nat
add action=netmap chain=dstnat protocol=17(UDP) dst-port=10000-20000 In-interface=uplink to-adresses=192.168.1.50 to-ports=10000-20000


что сделать чтобы размножить для всех телефонов?
 
Зачем что то размножать? Телефоны сами открывают нужные порты из за ната, проверено неоднократно. Если телефоны стоят за микротиком в локалке а коннектятся куда то к внешнему sip серверу - все работает. Главное на сип сервере этом указать что телефон находится за натом, есть там такая галочка обычно.
 
Цитата
Зачем что то размножать? Телефоны сами открывают нужные порты из за ната, проверено неоднократно. Если телефоны стоят за микротиком в локалке а коннектятся куда то к внешнему sip серверу - все работает. Главное на сип сервере этом указать что телефон находится за натом, есть там такая галочка обычно.


При правильной работе SIP ALG так и должно происходить, но хваленный MICROTIK явно подкачал -- ну не работает у него эта функция с провайдером SIP BEELINE -- Судя по всему придется его в помойку
 
попробуйте включить /ip upnp, указать какой внешний интерфейс и какой внутренний, правила будут создаваться автоматически, а также разрешить в фаерволе инпут и форвард трафика.
 
Цитата
попробуйте включить /ip upnp, указать какой внешний интерфейс и какой внутренний, правила будут создаваться автоматически, а также разрешить в фаерволе инпут и форвард трафика.

Алексей, UPNP тоже все перепробовал -- не помогает -- и UPNP через консоль тоже (просто есть мнение, что через Winbox некорректно работает)

Вообще есть мнение, что VOIP трафик не по зубам многим разновидностям NAT.

"Протоколы VoIP могут работать некорректно в сетях, включающих в себя некоторые виды протоколов NAT или компоненты брандмауэров. В результате голосовая связь может быть односторонней, либо обрываться. Односторонняя связь, как правило, является следствием использования в сети double NAT issue или враждебного NAT transversal. Сам по себе протокол VoIP является проблемным для протокола NAT, поскольку обычные протоколы, используемые им, взаимодействуют установлением соединения и передачей данных."
 
Цитата

При правильной работе SIP ALG так и должно происходить, но хваленный MICROTIK явно подкачал -- ну не работает у него эта функция с провайдером SIP BEELINE -- Судя по всему придется его в помойку
Категорически с вами не согласен. Все настроить можно. И микротик в том числе. И никакой SIP ALG для этого не нужен. Для начала, я понятия не имею как работает sip у билайна и в принципе мог бы вам помочь на досуге поразбираться (самому интересно) если вы дадите больше данных про сип билайна и возможно аккаунт самого номера. Вслепую можно только ванговать а мы тут не за этим собрались конечно же.
 
Надеюсь что каждому телефону назначен свой ip адрес как внешний так и внутренний или вы пытаетесь подключаться на один внешний адрес ко всем телефонам ?
 
Цитата
Цитата

При правильной работе SIP ALG так и должно происходить, но хваленный MICROTIK явно подкачал -- ну не работает у него эта функция с провайдером SIP BEELINE -- Судя по всему придется его в помойку
Категорически с вами не согласен. Все настроить можно. И микротик в том числе. И никакой SIP ALG для этого не нужен. Для начала, я понятия не имею как работает sip у билайна и в принципе мог бы вам помочь на досуге поразбираться (самому интересно) если вы дадите больше данных про сип билайна и возможно аккаунт самого номера. Вслепую можно только ванговать а мы тут не за этим собрались конечно же.


Сделать аналог SIP ALG самостоятельно я точно не потяну да и овчинка выделки не стоит -- проще сменить роутер.

Особенность Билайна в том, что он обратно поток возвращает со своего "Медиа сервера" 195.239.174.71    , а не от туда где его запрашивали.

Аккаунт самой линии дать не получится  -- нет возможности смены пароля -- выдавал сам Билайн -- отдельные настройки на каждую линию
(Добавление)
Цитата
Надеюсь что каждому телефону назначен свой ip адрес как внешний так и внутренний или вы пытаетесь подключаться на один внешний адрес ко всем телефонам ?

Внешний у меня пока только один -- дополнительные стоят денег -- а мне их два десятка надо -- для решения проблемы и нужна SIP ALG (кстати у routeros это же включается в /ip firewall service ports sip).  Может кто действительно знает как самому на ROUTEROS аналог SIP ALG замутить.
 
Цитата
Внешний у меня пока только один -- дополнительные стоят денег -- а мне их два десятка надо

На сип сервере должна быть возможность в аккаунтах указать на какой адрес и порт ломиться на телефон, и делать проброс порта на внутренний адрес, реален вариант с одним адресом для нескольких телефонов с пробросом разных портов

Цитата
для решения проблемы и нужна SIP ALG (кстати у routeros это же включается в /ip firewall service ports sip).  Может кто действительно знает как самому на ROUTEROS аналог SIP ALG замутить.

Выдержка из разных документаций, насколько достоверно надо проверять, везде рекомендуют отключать SIP ALG и делать проброс портов
1
Особенность реализации SIP ALG заключается в том, что он работает только на порту 5060. При использовании другого номера порта механизм SIP ALG не будет работать.
2
Все устройства с NAT  должны поддерживать механизм SIP ALG. Если на пути прохождения SIP-пакетов будет находиться устройство с NAT, которое не поддерживает SIP ALG, то в этом случае SIP-телефония не будет работать.
3
Так как определенные модели роутеров и сетевых экранов имеют  встроенную технологию передачи SIP протокола (прозрачное изменение SIP сообщений), которые призваны упростить работу с NAT, то использование стандартного порта 5060 при такой конфигурации будет не упрощать работу, а наоборот, усложнять, т.к. нужно использовать либо проброс, либо sip alg.

В самом телефоне так же как и на сип сервере должна быть включена работа через нат.
То что вы нашли на микротике сервис с портами 5060, 5061 думаю надо отключить.
 
Повторюсь - ничего в микроте не отключал и не трогал. В роли sip сервера использую kerio operator за натом, у которого открыт только 1 порт наружу - 5060. В свойствах добавочных номеров которые за натом из такого же микрота просто указал галку - добавочный номер после НАТ и все заработало а пока галки не было - слышимость была односторонняя. При этом, в настройке керио оператора убрал галочку что он сам стоит за натом и только определил диапазон портов используемых для RTP.
 
Звонил, искал в админке -- порт поменять не дают -- всегда один


Цитата
для решения проблемы и нужна SIP ALG (кстати у routeros это же включается в /ip firewall service ports sip).  Может кто действительно знает как самому на ROUTEROS аналог SIP ALG замутить.

1
Все равно заменить возможности нет.

2
У меня три вида устройств -- D-link DPH-150s, Yealink SIP-T26P, софт телефон X-lite последней версии -- у всех есть поддерка работы через NAT

3
проброс работает на microtik работает замечательно, но только для одного телефона, а dip alg вообще не работает.
 
Цитата
а dip alg вообще не работает.

То что вы нашли на микротике сервис и есть SIP ALG, отключите его и включите upnp на микротике.
 
Цитата
Повторюсь - ничего в микроте не отключал и не трогал. В роли sip сервера использую kerio operator за натом, у которого открыт только 1 порт наружу - 5060. В свойствах добавочных номеров которые за натом из такого же микрота просто указал галку - добавочный номер после НАТ и все заработало а пока галки не было - слышимость была односторонняя. При этом, в настройке керио оператора убрал галочку что он сам стоит за натом и только определил диапазон портов используемых для RTP.

В моем случае  -- можно управлять только вторым микротом.
Где там добавочные номера в микроте -- можно подробнее с правилами с микрота
(Добавление)
Цитата
Цитата
а dip alg вообще не работает.

То что вы нашли на микротике сервис и есть SIP ALG, отключите его и включите upnp на микротике.

Когда отключаешь SIP ALG -- голос пропадает уже в обе стороны
так я тоже делал -- результат тот же.
 
Цитата
Где там добавочные номера в микроте -- можно подробнее с правилами с микрота
А там где добавочные номера - вообще нету правил для ната, связанных с сипом и его портами, открыт только 48510 порт на торренты (проброшен на конечную машину) и все. В упомянутых /ip/services/ sip и порт 5060 не присутствуют. Пакет может какой то надо дополнительный?
 
Цитата
Цитата
Где там добавочные номера в микроте -- можно подробнее с правилами с микрота
А там где добавочные номера - вообще нету правил для ната, связанных с сипом и его портами, открыт только 48510 порт на торренты (проброшен на конечную машину) и все. В упомянутых /ip/services/ sip и порт 5060 не присутствуют. Пакет может какой то надо дополнительный?

/ip/services/ sip  -- ну он же там есть и горит зелененьким -- значит SIP ALG у вас работает  -- вот и получается, что с какими то SiP серверами микротики работают, а с какими то нет.
 
/ip/services/ sip   нету. Есть api ssh ftp telnet www winbox www-ssl  а вот sip нету. Версия OS 6.28
Страницы: 1