0 Список сравнения
0 Избранные товары
0
Страницы: 1
Проблема с vlan и trunk
 
Добрый день! Настраиваю в точности по примеру как в вики, но почему-то не работает, подскажите плиз что упустил.
http://wiki.mikrotik.com/wiki/Manual:CRS_examples
Example 1 (Trunk and Access ports)

У меня следующий конфиг
Цитата

/interface ethernet
set [ find default-name=ether21 ] master-port=ether24
set [ find default-name=ether22 ] master-port=ether24

/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=21 ports=ether21 sa-learning=yes
add customer-vid=0 new-customer-vid=22 ports=ether22 sa-learning=yes

/interface ethernet switch egress-vlan-tag
add tagged-ports=ether24 vlan-id=21
add tagged-ports=ether24 vlan-id=22

/interface ethernet switch vlan
add ports=ether21,ether24 vlan-id=21
add ports=ether22,ether24 vlan-id=22


/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports=ether24,ether21,ether22

На транкпорту работает centos
настроены интерфейсы
ifcfg-eth1.21 и ifcfg-eth1.22

VLAN=yes
DEVICE=eth1.ХХ
ONBOOT=yes

Ну и проблема в том что три девайса, подключенные в эти порты, друг друга не видят.

Настраивал эту же конструкцию через бриджи - работает
Цитата

/interface bridge
add name=bridge21
add name=bridge22

/interface vlan
add interface=ether24 l2mtu=1584 name=vlan21 vlan-id=21
add interface=ether24 l2mtu=1584 name=vlan22 vlan-id=22

/interface bridge port
add bridge=bridge21 interface=vlan21
add bridge=bridge21 interface=ether21
add bridge=bridge22 interface=vlan22
add bridge=bridge22 interface=ether22
Страницы: 1