0 Список сравнения
0 Избранные товары
0
Страницы: 1
Отключение интерфейса при добавлении в бридж
 
Всем привет!
Делаю настройку Mikrotik по хелпу: http://forum.qwerty.ru/index.php?showtopic=353085&#entry3188347
Прошивка последняя.
Есть провайдер Qwerty, который даёт IP по DHCP. Ещё есть TV.
При дефолтных настройках (1-й порт получает интернет, остальные в локалке) делаю второй бридж, куда пихаю 1-й и 5-й (для ТВ) порты.
Как только я это делаю, сразу пропадает интернет, интерфейс 1 становится inactive, но ТВ работает.
Что я делаю не так и как это можно поправить?
Я хочу получить одновременно и NAT (WiFi и локалка) и Bridge (для ТВ).
 
уберите в настройках 5-ого порта привязку ко 2-ому мастер-порту...
 
Цитата
уберите в настройках 5-ого порта привязку ко 2-ому мастер-порту...
Это я делал, так как без этого порт не добавляется в бридж.
 
Цитата
Цитата
уберите в настройках 5-ого порта привязку ко 2-ому мастер-порту...
Это я делал, так как без этого порт не добавляется в бридж.

Ставте версию 5.26, на ней интерфейсы не отключаются.
 
Цитата
Ставте версию 5.26, на ней интерфейсы не отключаются.
Я думал, что есть что-то, что мешает интерфейсу подняться. Какая-нибудь настройка...
Смена прошивки не факт что поможет. Если совсем ничего не поможет, попробую.
Вчера попробовал настроить с нуля (удалил дефолтную конфигурацию). ТВ работает, роутрер пингует внешку (ранее этого не было (полагаю, что из-за опущенного интерфейса)), но интернета нету.
Есть ли какие-нибудь методы диагностики?
В логе, который можно вызвать из меню, мало полезной информации. Может, можно как-то повысить уровень логирования.
 
Правило ната нужно делать на мост а не на интерфейс ether1, раз у вас внешний интерфейс занесён в бридж
(Добавление)
Цитата
Я думал, что есть что-то, что мешает интерфейсу подняться. Какая-нибудь настройка...
Смена прошивки не факт что поможет. Если совсем ничего не поможет, попробую.

Это в 6 версиях так сделано, в 5 интерфейсы не отключаются.
 
Цитата
Правило ната нужно делать на мост а не на интерфейс ether1, раз у вас внешний интерфейс занесён в бридж
Это понятно.
Прикол был такой: если настроить DHCP-Server по дефолту (только во вкладке DHCP), то оно не выдавало default gateway. После настройки пула адресов с прямым указанием gateway во вкладке Networks, всё взлетело.
Цитата
Это в 6 версиях так сделано, в 5 интерфейсы не отключаются.
Так из-за чего это?
При настройки с нуля данный эффект не проявляется.
 
Цитата
Прикол был такой: если настроить DHCP-Server по дефолту (только во вкладке DHCP), то оно не выдавало default gateway. После настройки пула адресов с прямым указанием gateway во вкладке Networks, всё взлетело.

Сам dhcp сервер выдавать ни чего не будет, в разделе Networks нужно указывать какому компьютеру или сети с определённой маской выдавать те или иные параметры.
По умолчанию там прописывается сеть, вы или удалили запись правила или не настроили.
 
Цитата

Сам dhcp сервер выдавать ни чего не будет, в разделе Networks нужно указывать какому компьютеру или сети с определённой маской выдавать те или иные параметры.не настроили.
Зачем нужен DHCP и что он должен выдавать: https://ru.wikipedia.org/wiki/DHCP
Цитата
По умолчанию там прописывается сеть, вы или удалили запись правила или не настроили.
Она не создалась по умолчанию.
 
На любой системе нужно указывать в настройках dhcp сервера что и кому выдавать.
 
Прошил 5.* прошивку. Получил коробку без WiFi. Не понравилось.
Прошил обратно 6.30.
Сделал резет.
После этого интерфейс "падать" перестал на дефолтном конфиге. Чудеса.
Зато всё завелось.
Страницы: 1