0 Список сравнения
0 Избранные товары
0
Страницы: 1
Slave порты не видят друг друга
 
Добрый день.
Начал на днях конфигурировать роутер Microtik.
1. Сделал мастер порт
2. Slave портам установил мастер порт
Но сетевые устройства подключенные к двум slave портам не пингуют друг друга.
3. Правил в FireWall-е вообще нет никаких
4. Далее создал bridge для мастер порта
5. Создал DHCP для bridge и теперь раздаю IP динамически
но пинг между slave портами все равно не идет.

прошу помощи.
 
Цитата
Правил в FireWall-е вообще нет никаких

А трафик локальный кто будет разрешать.
Сбросте конфигурацию по умолчанию, и проверте работает или нет связь между портами.
(Добавление)
Цитата
Создал DHCP для bridge и теперь раздаю IP динамически

А зачем бридж если dhcp сервер можно поставить на мастер порт.
 
Цитата
А трафик локальный кто будет разрешать.
Сбросте конфигурацию по умолчанию, и проверте работает или нет связь между портами.
Именно так и делал, связи нет. Дефолтовая конфигурация после RESET-а не содержит вообще никаких записей в разделе IP/FireWall, NAT,.... Есть только пронумерованные порты и DHCP сервер.
Я обновлял прошивку на MikroTik RouterOS 6.30, по обновления все работало.

Как разрешить любой локальный траффик, не подскажите?
 
Цитата
Дефолтовая конфигурация после RESET-а не содержит вообще никаких записей в разделе IP/FireWall, NAT

Как это не содержит, должно сброситься по умолчанию и всё работать, в противном случае проверяйте кабели и сетевые карты которыми подключены к микротику.

Дайте команду в терминале и ответьте на вопрос утвердительно (Y), эта команда востановит настройки по умолчанию.

/system reset-configuration
 
Цитата
Цитата
Дефолтовая конфигурация после RESET-а не содержит вообще никаких записей в разделе IP/FireWall, NAT

Как это не содержит, должно сброситься по умолчанию и всё работать, в противном случае проверяйте кабели и сетевые карты которыми подключены к микротику.

Дайте команду в терминале и ответьте на вопрос утвердительно (Y), эта команда востановит настройки по умолчанию.

/system reset-configuration

Все так и делал, произвел сброс конфигурации, после чего появилось окно с кнопкой: Remove Configuration, ShowScript, OK.

Скрипт представляет из себя следующее:
Код
#| 
#| LAN Configuration:
#|     LAN Port: ether1-master-local;
#|     switch group: ether1 (master), ether2, ether3, ether4, ether5, ether6, ether7, ether8, ether9, ether10, ether11, ether12, ether13, ether14, ether15, ether16, ether17, ether18, ether19, ether20, ether21, ether22, ether23, ether24, sfp1
#|          (renamed with extensions '-master-local' and '-slave-local')
#|     LAN IP:    192.168.88.1;

:global action;
:log info "act=$action";


#-------------------------------------------------------------------------------
# Apply configuration.
# these commands are executed after installation or configuration reset
#-------------------------------------------------------------------------------
:if ($action = "apply") do={
# wait for interfaces
:while ([/interface ethernet find] = "") do={ :delay 1s; };

 /interface ethernet {
   set ether1 name=ether1-master-local;
   set ether2 name=ether2-slave-local;
   set ether3 name=ether3-slave-local;
   set ether4 name=ether4-slave-local;
   set ether5 name=ether5-slave-local;
   set ether6 name=ether6-slave-local;
   set ether7 name=ether7-slave-local;
   set ether8 name=ether8-slave-local;
   set ether9 name=ether9-slave-local;
   set ether10 name=ether10-slave-local;
   set ether11 name=ether11-slave-local;
   set ether12 name=ether12-slave-local;
   set ether13 name=ether13-slave-local;
   set ether14 name=ether14-slave-local;
   set ether15 name=ether15-slave-local;
   set ether16 name=ether16-slave-local;
   set ether17 name=ether17-slave-local;
   set ether18 name=ether18-slave-local;
   set ether19 name=ether19-slave-local;
   set ether20 name=ether20-slave-local;
   set ether21 name=ether21-slave-local;
   set ether22 name=ether22-slave-local;
   set ether23 name=ether23-slave-local;
   set ether24 name=ether24-slave-local;
   set sfp1 name=sfp1-slave-local;
   set ether2-slave-local master-port=ether1-master-local;
   set ether3-slave-local master-port=ether1-master-local;
   set ether4-slave-local master-port=ether1-master-local;
   set ether5-slave-local master-port=ether1-master-local;
   set ether6-slave-local master-port=ether1-master-local;
   set ether7-slave-local master-port=ether1-master-local;
   set ether8-slave-local master-port=ether1-master-local;
   set ether9-slave-local master-port=ether1-master-local;
   set ether10-slave-local master-port=ether1-master-local;
   set ether11-slave-local master-port=ether1-master-local;
   set ether12-slave-local master-port=ether1-master-local;
   set ether13-slave-local master-port=ether1-master-local;
   set ether14-slave-local master-port=ether1-master-local;
   set ether15-slave-local master-port=ether1-master-local;
   set ether16-slave-local master-port=ether1-master-local;
   set ether17-slave-local master-port=ether1-master-local;
   set ether18-slave-local master-port=ether1-master-local;
   set ether19-slave-local master-port=ether1-master-local;
   set ether20-slave-local master-port=ether1-master-local;
   set ether21-slave-local master-port=ether1-master-local;
   set ether22-slave-local master-port=ether1-master-local;
   set ether23-slave-local master-port=ether1-master-local;
   set ether24-slave-local master-port=ether1-master-local;
   set sfp1-slave-local master-port=ether1-master-local;
 }

 /ip address add address=192.168.88.1/24 interface=ether1-master-local comment="default configuration";
}

#-------------------------------------------------------------------------------
# Revert configuration.
# these commands are executed if user requests to remove default configuration
#-------------------------------------------------------------------------------
:if ($action = "revert") do={
   :local o [/ip dhcp-client find comment="default configuration"]
   :if ([:len $o] != 0) do={ /ip dhcp-client remove $o }
 /ip dns {
   set allow-remote-requests=no
   :local o [static find name=router address=192.168.88.1]
   :if ([:len $o] != 0) do={ static remove $o }
 }
 /ip address {
   :local o [find comment="default configuration"]
   :if ([:len $o] != 0) do={ remove $o }
 }
# reset ethernets
 :foreach iface in=[/interface ethernet find] do={
   /interface ethernet set $iface name=[get $iface default-name]
   /interface ethernet set $iface master-port=none
 }
 /interface set [find name~"wlan1"] name=wlan1
 /interface wireless reset-configuration wlan1
 /interface set [find name~"wlan0"] name=wlan0
 /interface wireless reset-configuration wlan0
}


Я не вижу тут никаких команд по организации маршрутизации внeтри LAN.
 
Код
/ip dns {
 set allow-remote-requests=no

Тут должно быть yes иначе интернета не будет.

Цитата
Я не вижу тут никаких команд по организации маршрутизации внeтри LAN.
Вся маршрутизация сводится к тому что порты обьедены в свич и если у компьютеров адреса и маска из одной подсети то должны работать.
Вообще надо смотреть не скрипт а делать экспорт конфига
/export file=config.rsc

В скрипте не видно что бы он устанавливал dhcp сервер на мастер порт, и если все порты обьеденены в свич то к какому порту тогда шнурок интернета от провайдера, или по вайфай.
Если есть свич попробуйте сначала свич подключить к микротику а к свичу уже компьютер.
 
Код
# jul/21/2015 16:31:43 by RouterOS 6.30
# software id = 1HMI-HZM0
#
/interface ethernet
set [ find default-name=ether1 ] name=ether1-master-local
set [ find default-name=ether2 ] master-port=ether1-master-local name=\
    ether2-slave-local
set [ find default-name=ether3 ] master-port=ether1-master-local name=\
    ether3-slave-local
set [ find default-name=ether4 ] master-port=ether1-master-local name=\
    ether4-slave-local
set [ find default-name=ether5 ] master-port=ether1-master-local name=\
    ether5-slave-local
set [ find default-name=ether6 ] master-port=ether1-master-local name=\
    ether6-slave-local
set [ find default-name=ether7 ] master-port=ether1-master-local name=\
    ether7-slave-local
set [ find default-name=ether8 ] master-port=ether1-master-local name=\
    ether8-slave-local
set [ find default-name=ether9 ] master-port=ether1-master-local name=\
    ether9-slave-local
set [ find default-name=ether10 ] master-port=ether1-master-local name=\
    ether10-slave-local
set [ find default-name=ether11 ] master-port=ether1-master-local name=\
    ether11-slave-local
set [ find default-name=ether12 ] master-port=ether1-master-local name=\
    ether12-slave-local
set [ find default-name=ether13 ] master-port=ether1-master-local name=\
    ether13-slave-local
set [ find default-name=ether14 ] master-port=ether1-master-local name=\
    ether14-slave-local
set [ find default-name=ether15 ] master-port=ether1-master-local name=\
    ether15-slave-local
set [ find default-name=ether16 ] master-port=ether1-master-local name=\
    ether16-slave-local
set [ find default-name=ether17 ] name=ether17-WAN1
set [ find default-name=ether18 ] name=ether18-WAN2
set [ find default-name=ether19 ] name=ether19-WAN3
set [ find default-name=ether20 ] name=ether20-WAN4
set [ find default-name=ether21 ] name=ether21-FREE
set [ find default-name=ether22 ] name=ether22-FREE
set [ find default-name=ether23 ] name=ether23-FREE
set [ find default-name=ether24 ] name=ether24-FREE
set [ find default-name=sfp1 ] name=sfp1-FREE
/ip pool
add name=PCPool ranges=192.168.88.21-192.168.88.60
/ip dhcp-server
add add-arp=yes address-pool=PCPool disabled=no interface=ether1-master-local \
    name=DHCPServer1
/ip address
add address=192.168.88.1 comment="default configuration" interface=\
    ether1-master-local network=255.255.255.0
add address=176.xxx.xxx.49/24 interface=ether17-WAN1 network=176.xxx.xxx.0
/ip dhcp-server network
add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=195.xxx.xxx.3,193.xxx.xxx.3
/ip route
add check-gateway=ping distance=1 gateway=176.xxx.xxx.1
/lcd interface pages
set 1 interfaces="ether13-slave-local,ether14-slave-local,ether15-slave-local,\
    ether16-slave-local,ether17-WAN1,ether18-WAN2,ether19-WAN3"
/system clock
set time-zone-name=Europe/Moscow
/tool romon port
add


Вот так я настроил роутер.
Объединил порты на master порт но пинг между двумя компьютерами подключенных к SLAVE портам не идет. Хотя IP адреса им выдаются и их видно в DHCP Leases
 
Код
/ip dhcp-server
 add add-arp=yes


А эту настройку вы сами включили или нет, попробуйте убрать галочку, микротик сам определит и добавит в arp
А где конфиг фаервола, приведён не весь конфиг.
И конфиг интерфейсов вот такой командой

Код
/interface ethernet export verbose file=interface.rsc
 
Большое спасибо alexnov66. С вопросом разобрался.
Страницы: 1