0 Список сравнения
0 Избранные товары
0
Страницы: 1
CCR1016-12G Белый интернет, DNS resolvig fail
 
Добрый день.

Куплен CCR1016-12G.   V6.31.
Конфигурация:

/ip hotspot user profile
set [ find default=yes ]
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-128-cbc
/ip pool
add name=pool1 ranges=212.1.1.10-212.113.1.20
/ip dhcp-server
add address-pool=pool1 bootp-support=dynamic disabled=no interface=ether2 \
   name=server1
/ip accounting
set enabled=yes
/ip address
add address=192.168.96.61/24 interface=ether12 network=192.168.96.0
add address=172.26.0.124/28 interface=ether1 network=172.26.0.112
add address=212.1.1.1/24 interface=ether2 network=212.1.1.0
/ip dhcp-server network
add address=212.1.1.0/24 dns-server=8.8.8.8 gateway=\
   212.1.1.1 netmask=24
/ip dns
set allow-remote-requests=yes max-udp-packet-size=512 servers=\
   8.8.8.8
/ip firewall filter
/ip firewall mangle
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
/ip proxy

/ip route
add check-gateway=ping distance=1 gateway=172.26.0.113 routing-mark=WiFi-INET
add distance=1 dst-address=192.168.20.0/24 gateway=192.168.96.10
/ip route vrf
add comment="Internet Access" interfaces=ether1,ether2 routing-mark=WiFi-INET
/radius
add address=192.168.96.58 secret="secret" service=login src-address=\
   192.168.96.61
add accounting-port=1646 address=172.26.0.121 secret=mik2015 service=hotspot \
   src-address=172.26.0.124
/system package update
set channel=current
/system resource irq rps
set ether1 disabled=no
set ether2 disabled=no
set ether3 disabled=no
set ether4 disabled=no
set ether5 disabled=no
set ether6 disabled=no
set ether7 disabled=no
set ether8 disabled=no
set ether9 disabled=no
set ether10 disabled=no
set ether11 disabled=no
set ether12 disabled=no
/system routerboard settings
# Firmware upgraded successfully, please reboot for changes to take effect!
set cpu-frequency=1200MHz memory-frequency=1066DDR
/tool romon port
add
/user aaa
set default-group=full use-radius=yes


Пинг в интернет с самого микротика  только по IP.
По DNS имени :
ping www.mail.ru routing-table=WiFi-INET src-address=212.1.1.1
invalid value for argument address:
   invalid value of mac-address, mac address required
   invalid value for argument ipv6-address
   while resolving ip-address: could not get answer from dns server


Если подключаюсь компом в ether 2 (там где выдаются белые IP) то все прекрасно работает.

Подскажите как это лечится?  Ната у меня нет.
 
Цитата
Подскажите как это лечится?  Ната у меня нет.

А диапазон внутренней сети почему вы не натите ?
Это же адреса из диапазона адресов для локальных сетей.
 
Цитата

А диапазон внутренней сети почему вы не натите ?
У меня локальная сеть белые ip. Раздаю в lan белую сеть.
пытаюсь матчить днс запросы, нет пакетов в логах. По доменному имени пингую с сорсом (белый ip) .  И  еще, я использую vrf. Хотя и без него ситуация такая же.
 
Цитата
Цитата

А диапазон внутренней сети почему вы не натите ?
У меня локальная сеть белые ip. Раздаю в lan белую сеть.
пытаюсь матчить днс запросы, нет пакетов в логах. По доменному имени пингую с сорсом (белый ip) .  И  еще, я использую vrf. Хотя и без него ситуация такая же.

А это что разве адреса из диапазона интернета ?

Код
/ip address
 add address=192.168.96.61/24 interface=ether12 network=192.168.96.0


Вообще какая то хитрая настройка, по какому мануалу настраивали ?
Судя из приведённого скудного конфига порты ether1 ether2 внешние в сторону провайдера, и на них же установлен dhcp сервер
И dns сервер 8.8.8.8 может не всё отрабатывать, в первую очередь должен быть прописан dns вышестоящего провайдера.
 
На верху стоит Juniper ( на джуне есть дефолт от провайдера по  bgp) Провайдер выделяет мне подсеть 212.x.x.x.
Микротик цепляю к джуниперу через eth1 стыкую через сеть 172.26.0.112/28. На микротике делаю дефолт в сторону джунипера. В микротике  На eth2 поднимаю белую сеть(212.x.x.x) и dhcp.
eth12 - 192.168.96.0/24 сеть для управления микротиком.  
Все сделано чтоб не натить, выдавать клиенту белые ИП.

eth1 & eth2  находятся в vrf  wifi-inet

eth12  в глобале

Микротик увидел не так давно, кое что читал на оф сайте. Настройку делал не по мануалу а по логике работы сетей.
(Добавление)
И позвольте вопрос (раз уже мы начали общаться на тему микротика) -  Лучше всегда делать апргреды ПО на микртоике если имеется новый релиз? Периодически вижу на форумах что некоторые делают даунгрэйд - зачем?  Это зависит от рук? или действительно некоторый функционал в новых релизах не работает?
 
Есть поговорка, не ремонтируй то что работает, не стоит ставить новые версии, тем более 6.х, много выходят глючных версий, сначала ставят на отдельном микротике и тестируют, порой месяцами, если глюков не замечено в вашей конфигурации настроек то можно и обновить потом остальные, а глюки проявляются порой через несколько недель, вот и откатываются потом на предыдущие версии прошивок.

Новая версия ставится автоматически при загрузке её на микротик и последующей перезагрузке, команда
/system package downgrade
даётся если надо вернуться на предыдущюю версию.
 
В таком случае подскажите (посоветуйте ) какой релиз поставить? Судя по всему из- за софта вылазят неприятности с настройкой hotspot. День происходит редирект (в хотспоте) день не работает, как то так.
 
Цитата
В таком случае подскажите (посоветуйте ) какой релиз поставить? Судя по всему из- за софта вылазят неприятности с настройкой hotspot. День происходит редирект (в хотспоте) день не работает, как то так.

Трудно сказать какая у вас будет работать, попробуйте поставить последнюю 6.31, или 6.27, промежуточные версии между этими глючные, так же могут быть глюки не только от версии но и от настроек.

Попробуйте в мангле отмаркировать пакеты сети 212.1.1.0/24 и создать маршрут к сети 0.0.0.0/0 через шлюз провайдера, из приведённого кажется 172.26.0.113
Хотя у вас отмечено, но в мангле правила похоже нет
routing-mark=WiFi-INET
или сначала попробуйте снять маркировку пакетов с маршрута по умолчанию и проверить доступ в интернет. Вообще маршрут по умолчанию должен обязательно быть без всяких routing-mark, он нужен для самого микротика, для своих нужд, чтоб мануал работал в винбоксе, синхронизация времени самого микротика, резолвинг запросов к вышестоящим dns серверам ну и т.д т.п
А уже потом остальные маршруты с маркировкой пакетов если нужно ту или другую сеть пустить через определённого провайдера.
И выдавать dns сервер пользователям первый адрес микротика 212.1.1.1 а уже второй и последующие другие.

/ip route
add check-gateway=ping distance=1 gateway=172.26.0.113 routing-mark=WiFi-INET

И пинговать шлюз провайдера не разумно, он может быть доступен а интрнета может и не быть.
check-gateway=ping

И не забывайте чаще делать бекап системы и сбрасывать его к себе на компьютер что бы можно было потом востановить в случае неработоспособности тика или кривых рук.
 
Спасибо , буду пробовать.
 
В общем работает все но только если использовать NAT. При этом функция hotspot в связке с vrf не заработала, без vrf работает. Пока буду работать так.
Страницы: 1