Форум интернет-магазина Микрокомп
0 Список сравнения
0 Избранные товары
0
Страницы: 1
Переадресация на внутренний IP
 
Доброго времени суток! Имеется внешний белый IP 95.147.65.2, с которого проброшены порты на внутренний 192.168.5.12. Когда человек находится за пределами локальной сети - все работает отлично - подключается к серверу без проблем. Нужно сделать так, чтобы человек находясь и в локальной сети при обращении к тому же адресу 95.147.65.2,подключался также на 192.168.5.12. Стандартные dst-nat + netmap не работают. Понимаю что чего то еще не хватает, но вот чего? Спасибо!


Сам нашел решение, все таки dst-nat + netmap работает, просто в нем нужно было жестко указать:
src. address: 192.168.5.0/24
dst. address: 95.147.65.2
 
При пробросе на внутренний сервер используется dst-nat а не netmap, разве в мануале указано netmap ?

Netmap используется для транслирования одной подсети в другую а не одного адреса.

ps: откуда только берёте мануал об использовании netmap для проброса одного адреса.
 
Цитата
откуда только берёте мануал об использовании netmap для проброса одного адреса
Вот отсюда http://habrahabr.ru/post/182166/   ::confused1::

netmap — Отображение одного адреса на другой. Фактически, развитие dst-nat;

Раньше думал что это практически одно и то же, но с Вашим комментарием теперь я знаю немного больше :) Спасибо за подсказку. Кстати работает хорошо как с netmap так и с dst-nat :)
 
Для доступа пользователей на сервер по внешнему адресу создайте еще правило

Если с портом

Код
/ip firewall nat
add action=src-nat chain=srcnat dst-address=192.168.5.12 dst-port=80 protocol=tcp to-addresses=95.147.65.2 to-ports=0-65535


Если всех портов то без порта

Код
/ip firewall nat
add action=src-nat chain=srcnat dst-address=192.168.5.12 to-addresses=95.147.65.2


Вообще делается три правила на порт

Код
/ip firewall nat
add action=dst-nat chain=dstnat comment=dst_in_tcp_80 dst-address=\
    100.100.100.100 dst-port=80 protocol=tcp to-addresses=192.168.0.1 \
    to-ports=80
add action=src-nat chain=srcnat comment=src_out_tcp_80 protocol=tcp \
    src-address=192.168.0.1 src-port=80 to-addresses=100.100.100.100 \
    to-ports=80
add action=src-nat chain=srcnat comment=src_in_tcp_80 dst-address=\
    192.168.0.1 dst-port=80 protocol=tcp to-addresses=100.100.100.100 \
    to-ports=0-65535


Первое для проброса порта на внутренний сервер
Второе для ответов от сервера в внешний адрес и подмены внутреннего адреса внешним
Третье для доступа пользователей к серверу по внешнему адресу из внутренней сети
 
Спасибо за подробное описание, уже сделал все учтя Ваши рекомендации!
 
Доброго времени суток коллеги. Похожая ситуация. Подскажет может кто чем) Имеем:

1) Mikrot с адресом 192.168.1.1/24

2) Подключенный к нему на порт ethernet5 voip шлюз, где указан только ip адрес и нету default gateway. ip шлюза - 192.168.2.1/24

3) на интерфейсе ethernet5, у mikrota добавлен статичный ip 192.168.2.2/24 - для доступа к  устройству 192.168.2.1

4) Из микрота в удаленную сеть через интернет поднят PPTP туннель, ip сервера 172.16.1.1/24, ip на микроте 172.16.1.20/24

5) имеется sip server в удаленной сети, ip 172.16.1.30/24.

6) Из sip устройства 192.168.2.1/24 пинг и вообще все пакеты проходят только на 192.168.2.2/24 интерфейс, само собой потому, что нету гейтвея и не возможно там его прописать в принципе.

Собственно вопрос.
Какое правило в NAT нужно добавить, чтобы все пакеты, отправленные устройством 192.168.2.1 на адрес 192.168.2.2 (ибо только он один доступен), перенаправлялись только на ip 172.16.1.20. подскажите пожалуйста как правильно создать правило для НАТ.  Чтобы пакеты до и от 172.16.1.20 мапились на 192.168.2.1 в обе стороны.

Спасибо заранее.
Страницы: 1