Форум интернет-магазина Микрокомп
0 Список сравнения
0 Избранные товары
0
Страницы: 1
Отправление внешнего ip на email, Отправление внешнего ip на email
 
Добрый день!

Подскажите как написать скрипт чтоб при получении нового ip на pppoe интерфейсе он автоматически отправлял письмо на мой email о смене ip
(Добавление)
Отвечаю на свой вопрос  ::biggrin24.gif::
Код
/tool e-mail> print server: xxx.xxx.xxx.xxx:yyyyy from: "ваш@почтовыйЯщик" username: "логин" password: "пароль"

где ххх - ip адресс сервера: уууу - порт smtp

далее тестируем отправку писем

Код
/tool e-mail> send to="ваш@почтовыЯщик"    subject="test" body="Привет Твой Микротик "


если письмо пришло значит все работает нет смотрите настройки  вашего почтового сервера  ::cool24.gif::
да и конечно пишем все на английском микротик иногда не понимает ваш родной язык ::biggrin24.gif::

далее пишем скрипт который будет проверять ваш внешний ip


Код
/system script add name="ether1monitorIPchange" source={
 
  :global actualIP;
 
  :local newIP [/ip address get [find interface="ether1"] address];
 
  :if ($newIP != $actualIP) do={
    :put "ip address $actualIP changed to $newIP";
    :set actualIP $newIP;
    /tool e-mail send to="mypersonalemail@gmail.com"  subject="IP change detected by Mikrotik Script"  body=$actualIP server=xxx.xxx.xxx.xxx from="Ваш@почтовыйЯщик";
  }
}

ether1monitorIPchange - название скрипта
ether1 - порт который мы слушаем
xxx.xxx.xxx.xxx - ip вашего smtp сервера

далее делаем задачу для повторения этого скрипта раз в час

Код
/system scheduler add name=periodicIPcheck interval=1h on-event=ether1monitorIPchange


interval=1h -  интервал повторения скрипта
ether1monitorIPchange - название скрипта

ну как-то так ::biggrin24.gif::
 
цель данного скрипта? получение нового IP?
может использование DDNS спасет "отца русской демократии"?
 
На самом деле удобная вещь, в городской говнолокалке. Там динамика, которая висеть может месяцами не меняясь, но бывает нет нет дергают ее, так на емайл уведомление приходит, с новым адресом.
Страницы: 1