Форум интернет-магазина Микрокомп
0 Список сравнения
0 Избранные товары
0
Страницы: 1
Проблемы с mikrotik и PPPoE провайдера
 
Здравствуйте!
Прошу Вас помочь в решении проблемы.
У меня провайдер предоставляет доступ по протоколу PPPoE. Долгое время все работало нормально, но потом (возможно) провайдер сменил обрудования и начались проблемы - пропадание пакетов.
При этом у меня появляются ошибки на Ethernet интерфейсе к провайдеру - RX Fcs Error. Ошибки эти выпадают по нескольку раз в секунду.
На PPP интерфейсе проблем нет.
Я подумал, что дело в MTU и MSS, пробовал менять MTU как Ethernet интерфейсе вплоть до 1400 (на PPP я сразу выставил 1400) - результат тот же.
Добавлял в mangle правила смены MSS - такие же проблемы.
Менял порт и само устройство (у меня mikrotik 2011) - проблемы.
Менял витую пару - ошибки.
Заменил микротик на DLINK-DIR100 - ошибок на интерфейсах нет - все отлично.
Попробывал из 2х интерфейсов микротика сделать bridge и пропустить трафик провайдера на DLINK через него - подобные ошибки.
Ошибки (похоже) на L2 уровне - что делать?

С Уважением, Алексей.
 
Смотря на какое оборудование сменил провайдер/Какого вида ошибки? crc?fragment?
 
Посмотрите какой режим работы на интерфейсе подключенном к провайдеру, попробуйте подключить через свич. Попробуйте переобжать кабель с обоих концов.
 
Большое число (минимум 1 ошибка в 5 сек) RX Fcs Error
и пореже (штук 5-10 в минуту) Rx Align Error

Какое он оборудование поставил - не известно, по маку определит не удалось, ибо ни по одной мак базе не проходит

Со своей стороны переобжал, пробывал на 2 пары переделывать (ибо кабельным тестером 2 пары и видно).

менял скорости на интерфейсе 10h, 10f,100h,100f...

через единственный хаб (tplink 100 мегабитный) не соединился ни микротик, ни кинетик.

в кинетике ошибок на интерфейсе нет, скорость полная. никаких особенных правил в нате тоже нет.
 
Цитата
менял скорости на интерфейсе 10h, 10f,100h,100f.

Посмотрите режим работы интерфейса к провайдеру, в автоматическом режиме, full duplex или half duplex, косяк у провайдера в настройках скорее всего.
Нельзя исключать неисправность и интерфейса самого микротика и неправильных настроек.
 
Цитата
Посмотрите режим работы интерфейса к провайдеру, в автоматическом режиме, full duplex или half duplex, косяк у провайдера в настройках скорее всего.
Нельзя исключать неисправность и интерфейса самого микротика и неправильных настроек.

режимы работы а автомате 100-full. У провайдера все (по идее) все нормально, так как другие (тплинк, зиксель) идеально работают. Думаю все-таки мои кривые руки...
только вот понять не могу, где кривизна. Ибо обычно все сводится к ошибке связанной с mtu, и на интерфейсе ошибок в принципе нет. Хотя, там (судя по всему) дофига мультикаст трафика, может быть ошибки именно из-за него.
(Добавление)
Микротики я менял... на 951... (2 пробывал для чистоты эксперемента). Сразу после дефолтной настройки просто добавлял PPPoE и смотрел, что получилось.
Страницы: 1