0 Список сравнения
0 Избранные товары
0
Страницы: 1
Кака настроить доступ к разным ресурсам с разных провайдеров?
 
Добрый день.
Суть вопроса такая. Имеется 2 провайдера: первый ,быстрый второй медленный. Второй предоставляет корпоративную почту и отключить его нельзя, а на первом доступа к почтовому серверу mail.***.ru нет через почтовые клиенты. Пользователи сети напрочь отказываются пользоваться вэб интерфейсом. Необходимо настроить микротик так чтобы доступ к почтовому серверу mail.***.ru был только со второго провайдера (точнее сказать чтобы доступ был только к почтовому серверу по портам 110, 25 и 143), а ко всем остальным ресурсам инета доступ был только через первого провайдера. Реально такое или нет?
Заранее спасибо.

При применении следующего инет вообще отваливается:
/ip firewall mangle
add action=mark-connection chain=input in-interface=ether1 new-connection-mark="isp1 in" passthrough=no
add action=mark-routing chain=output connection-mark="isp1 in" new-routing-mark=isp1 passthrough=no
add action=mark-connection chain=input in-interface=ether2 new-connection-mark="isp2 in" passthrough=no
add action=mark-routing chain=output connection-mark="isp2 in" new-routing-mark=isp2 passthrough=no


/ip route
add distance=1 gateway='шлюз ISP1' routing-mark=isp1
add distance=1 gateway='шлюз ISP2' routing-mark=isp2


Затем

/ip firewall layer7-protocol
add name=via_isp2 regexp="^.+(mail.***.ru).*\$"


ip firewall mangle
add action=add-dst-to-address-list address-list=isp2_addlist address-list-timeout=1d chain=prerouting disabled=no layer7-protocol=via_isp2 src-address=192.168.0.0/24
add action=mark-routing chain=prerouting disabled=no dst-address-list=isp1_addlist new-routing-mark=mail.***.ru passthrough=no
add action=mark-routing chain=prerouting disabled=no dst-address=!192.168.0.0/24 new-routing-mark=office passthrough=no


/ip route
add distance=10 gateway='шлюз ISP2' routing-mark=mail.***.ru
add distance=10 gateway='шлюз ISP1' routing-mark=office

Что не так?
 
Откуда вы взяли такие правила перенаправления.
Нужно метить только то что пойдёт через второго провайдера, остальное будет идти по маршруту по умолчанию через первого.

Код
/ip firewall mangle
add action=mark-connection chain=prerouting comment=to_isp2 dst-address-list=\
    list_mail_all dst-port=25,110,143 new-connection-mark=to_isp2_conn \
    passthrough=yes protocol=tcp src-address-list=list_ip_all
add action=mark-routing chain=prerouting connection-mark=to_isp2_conn \
    dst-address-list=list_mail_all dst-port=25,110,143 new-routing-mark=\
    to_isp2_rout passthrough=no protocol=tcp src-address-list=list_ip_all


Или даже так
Код
/ip firewall mangle
add action=mark-connection chain=prerouting comment=to_isp2 dst-port=\
    25,110,143 new-connection-mark=to_isp2_conn passthrough=yes protocol=tcp \
    src-address-list=list_ip_all
add action=mark-routing chain=prerouting connection-mark=to_isp2_conn \
    dst-port=25,110,143 new-routing-mark=to_isp2_rout passthrough=no \
    protocol=tcp src-address-list=list_ip_all


В адрес лист list_ip_all все адреса внутренней сети.
В адрес лист list_mail_all все адреса удалённые которые будут идти через второго провайдера.
В первом правиле перенаправления нужно включать passthrough=yes
 
alexnov66 может быть подскажете, существует ли способ для микрота сделать доступным с двух ISP со своими масками и шлюзами 1 внутренний сервер в локалке? Как научить микрот этому? Есть сип сервер в локалке, нужно чтобы к нему подключаться могли как по isp1 так и по isp2 по выбору. Ваши примеры выше будут хорошо работать например для того, чтобы некий диапазон ip отправить полностью через isp1 а все остальное пойдет через isp2. Но это не пойдет. Нужны равноценные доступы с обеих isp
 
Попробуйте такой вариант настроек, сам не пробовал, отпишитесь будет ли работать.
https://asp24.ru/mikrotik/pravilnyy-dst-nat-pri-ispolzovanii-2-h-i-bolee-provayderov-na-mikrotik/
Страницы: 1