0 Список сравнения
0 Избранные товары
0
Страницы: 1 2 След.
Перезагрузка МиКротиКА при разрыве связи с интернетом ???
 
Господа умники)) доброго времени суток! У кого есть опыт в настройке микротика в перезагрузку при обрыве связи с интернетом ???. Сижу на YOTA (LU-150) с уличной антенной. Всё это собрано на базе х86, работает бодро  , но возникают иногда обрывы связи с интернетом (модем теряет тупо сигнал), так вот ))) кто может подсказать как создать скрипт чтоб енто творение уходило в перезагрузку???  ::blink.gif::
 
watchdog не подходит?
 
Посмотрел это творение, согласен тема, но, не то(((( тут проще, без лишнего железа))) скрипт просто надо загнать нужный ::smile24.gif::
(Добавление)
моя мысль такова чтоб проходил пинг куда либо в интернет, а вот если его не будет вот тогда погнали в ребут))) а вот как замутить не соображу не силён я в линуксах((
 
Цитата
Посмотрел это творение, согласен тема, но, не то(((( тут проще, без лишнего железа))) скрипт просто надо загнать нужный ::smile24.gif::
(Добавление)
моя мысль такова чтоб проходил пинг куда либо в интернет, а вот если его не будет вот тогда погнали в ребут))) а вот как замутить не соображу не силён я в линуксах((

Тут есть скрипт перезагрузки VPN соединения, по аналогии сделайте вам нужный.
 
http://wiki.mikrotik.com/wiki/Manual:System/Watchdog

Что может быть проще. Это встроенная команда. Ребут по таймауту 6 пингов.
 
Тупанул((( нашёл USB железяку с таким же названием и смыслом посчитал зачем мне лишнее, а потом нашёл утилитку, но вот вопрос, первый пинг она посылает сразу после загрузки (с нетватч не получилось(( микротик пошёл в постоянный перезагруз без остановки, так как ёта видать не успевала подкидываться) или по истечении какого то времени???
 
Какая утилитка? Где сам скрипт?
 
попробуйте периодически запускать скрипт типа
Код
if ([ping 8.8.8.8 count=3 interface=[/interface ppp-client find comment="yota"]]=0) do={
  /interface ppp-client disable [find comment="yota"]; 
  :delay 10; 
  /interface ppp-client enable [find comment="yota"]; 
  ping 8.8.8.8 count=10 interface=[/interface ppp-client find comment="yota"] ; 
  if ([ping 8.8.8.8 count=3 interface=[/interface ppp-client find comment="yota"]]=0) do={
  /system reboot;} 
  }  

предварительно снабдив интерфейс йоты комментом yota...
может спасет просто "передергивание"  интерфейса... если нет - ребут...
 
Эврика ::biggrin24.gif::  нашел скрипт, выкладываю

:local PingCount 3
:local google 8.8.8.8
:local yandex 77.88.8.8
:local mail  94.100.180.201
:local ResultGoogle [/ping count=$PingCount $Google interface=yota]
:local Resultyandex [/ping count=$PingCount $yandex interface=yota]
:local ResultMail [/ping count=$PingCount $mail interface=yota]
:local MainIfInetOk false;
:set MainIfInetOk (($ResultGoogle + $Resultyandex + $ResultMail) >= (2 * $PingCount))
:put "MainIfInetOk=$MainIfInetOk"
if (!$MainIfInetOk) do={
/log error "Bad connect"
/system routerboard usb power-reset
/system reboot
}
if ($MainIfInetOk) do={
/log info "Connect OK"
}


но так как у меня yota то и интерфейс я указал её, в шудлере задал startup и через каждые 5 минут.
(Добавление)
Цитата
зайди в систем и в самом низу увидишь ватчдог который и спасает от зависания оборудования ::biggrin24.gif::
 
есть параметр указывающий задержку после загрузки до первого пинга
 
Вижу что нету но скрипт работает без косяков ))) есть сила мысли как добавить таймаут в этот скрипт???
 
Такой командой можно выключить модем на usb порту на указанное время.

duration=10s выключает питание на usb порту на 10 секунд

Код
/system routerboard usb power-reset duration=10s
 
Можно! не спорю))) но эта команда для х86 не рабочая(((
 
Цитата
Можно! не спорю))) но эта команда для х86 не рабочая(((

Можно дать команду отключить а потом включить usb интерфейс, перезагрузится или нет модем нужно проверить.
В скрипте если нужно выполнить следующую команду через время, прописывается delay между командами, то есть выполнить через секунду

Код
delay 1;


или через 10 секунд

Код
delay 10;


Запись в скрипте для отключения интерфейса и потом его включения
Где local3 имя интерфейса, включить его через 15 секунд

Код
/interface disable local3;
delay 15;
/interface enable local3;
 
Что то я запутался сам скрипт рабочий который выложил BLOODER? Или в нем есть какие то минусы?
 
Рабочий!!! от и до!!! только надо поменять интерфейсы на которые будут посылаться запросы, у меня к примеру стоит YOTA вот он и нацелен на нее, а вы можете указать свои ::biggrin24.gif::
 
Цитата
Рабочий!!! от и до!!! только надо поменять интерфейсы на которые будут посылаться запросы, у меня к примеру стоит YOTA вот он и нацелен на нее, а вы можете указать свои ::biggrin24.gif::

Спасибо за скрипт, у меня еще один вопрос, после перезапуска MikroTik, скрипт нужно по новой запуск или он автоматически запускается, я имею ввиду команду Run Script?
 
Цитата
Спасибо за скрипт, у меня еще один вопрос, после перезапуска MikroTik, скрипт нужно по новой запуск или он автоматически запускается, я имею ввиду команду Run Script?

Кнопка run script предназначена для ручного запуска скрипта, скрипт запускается по команде с шедулера.

Зачем в скрипте передёргивать usb интерфейс а потом еще и перезагружать микротик полностью, достаточно только отключить питание на usb интерфейсе, а еще быстрее переподключить подключение к провайдеру.

Код
/log error "Bad connect"
 /system routerboard usb power-reset
 /system reboot
 }
 
вроде как рабочий скрипт? ПРОВЕРЬТЕ

Код
:local PingCount 3

#www.ru
:local PingTarget1 194.87.0.50

#yandex.ru
:local PingTarget2 87.250.250.203

#google dns
:local PingTarget3 8.8.8.8


:local PingResult1 [/ping $PingTarget1 count=$PingCount interface=internet]
:local PingResult2 [/ping $PingTarget2 count=$PingCount interface=internet]
:local PingResult3 [/ping $PingTarget3 count=$PingCount interface=internet]

:local ping (($PingResult1 + $PingResult2 + $PingResult3) >= (2 * $PingCount))

/log warning "ping 1 otvetov $PingResult1"
/log warning "ping 2 otvetov $PingResult2"
/log warning "ping 3 otvetov $PingResult3"
/log warning "ping $ping"
if ($ping=true) do={
/log error " kanal zhiv"
}
if ($ping=false) do={
/log error " kanal down reconnect"
/interface internet disable
:delay 15;
/interface internet enable
}
 
Все скрипты зависают когда нет инета. причина в Ping

когда в терминале вводится  

/log info  [/ping 8.8.8.8 count=3 interface=LTEBGD] то получается при отсутствии соединения ping ожидает ответа до бесконечности.

как решить проблему ?
Страницы: 1 2 След.